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What’s new in Version 7

SCSItoolbox32 (STB) Additional Features & Tests

Disk Performance/Error Graphing Test

This test is accessed from the Disk->Tests->Performance/Error Graph menu choice.

This test enables you to quantify the real-world 1/0 performance of a disk drive. It supplies a macro view
of the entire drive that also provides a micro view of all problem areas. In the case of disk read
performance, you need to read all blocks on the drive and record the time each read takes to complete.
The shorter the completion times the better. To visualize this data it is graphed as block-number versus
I/0 Completion time.



Look at the graph in Figure 1 —the X axis is the block number read and the Y axis is the time it took the
READ I/0O to complete. The Red plot shows the slowest I/O time out the past 100 reads. The Green plot
shows the average completion time of the last 100 reads, and the Blue plot shows the average of all
reads.
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Figure 1

Notice the large difference between the slowest /0 completion time and the average. In this case
something is causing the drive to take much longer to complete the read. Also notice the correlation
between the Red and Green plots. Since the Green plots show the average completion time across 100
I/0’s these plots will indicate how many of the 1/O’s are slow.

For example at block number 400,000 the Red plot showed .05 seconds, and the Green shows around
.012. This tells us that there were just a few blocks within a 100 block range that had trouble. On the
other hand, at block 600,000 we see the Red plot peaking again around .06, while the Green average is
almost the same. This would indicate that most if not all the blocks in this region are having trouble.



What causes slow I/0 completion times? Usually it stems from the drive having to do varying degrees of
error correction. We recommend looking at two suspect areas, grown defects and error correction
counts.

Figure 2 shows the Primary defect list of the drive, Figure 3 shows there are no Grown defects

Disk Drive Defect Information

Primary Defects Grown Defects Defect List Format
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Figure 2



Disk Drive Defect Information

Primary Defects | Grown Defects Defect List Format

[ Buytes from Index

Defect Data Type = Block addreszs * Block

Mumber of Defects = 0 " Physical Sectar

There are no Grown
defects

Cancel Print Save to File |

Figure 3

This implies that the problem is not related to the drive accumulating defects. That leaves the question
of is the drive having to do excessive amounts of error correction which in turn is slowing command
execution? To confirm this you must examine the Error Correction logs for the drive. A summary of
these logs is shown in Figure 4.
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0K complete the READ commands.

Figure 4
As noted in Figure 4, the drive is recording many read retry efforts.

What causes retries? Why would the drive need to retry the read operation? It could be a number of
issues, from media damage due to a head crash, wear and aging of the media, servo tracking problems
possibly cause by temperature extremes or power loss during writes, etc. Retries over a very large block
range may indicate disk head or preamp problems.

To verify if the problem stems from a permanent problem or not we recommend two steps —

1. Reformat the drive — this will erase any grown defects and replace them if the format media

scan shows a problem.
2. Write to all blocks of the drive. This will force the drive to update both sector data and error

correction code data.

After performing these two steps run the Performance/Error graph test again and note any differences —
as Figure 5 shows the problem area still has a few blocks that are reading slow, but the average I/0
completion time is now low. Again, this indicates that only a few blocks are having problems.



N Disk Performance/Error Test

Disk Performance/Error Test Results

Figure 5

Checking the drive Error Correction logs in Figure 6 now shows fewer corrections are happening — the
format/write process was able to repair the problem. It would still be prudent to watch the drive —
occasionally run the same test and log examination sequence to be sure that the problem was indeed
temporary.



Load/Execute BAM Trace in CDB Sequencer

This new feature gives you the ability to issue a series of CDB’s which were captured using BAM. It is

accessed by the new CDB Sequencer Load BAM File choice — specify a file previously made using the
BAM Save to CDB Seq File option:

CDB Sequencer

Load BAM Output from file

Load from File

Load B File

Cancel



This will create a new command definition file and new history entries in the Command History Window.

An example of the new command definition file is here:

Available Commands

Comrnand Marme | CDE Buytes ~
370015 000000 0000 04 00 37 0015 00 00 00 00 00 04 00
370000 0000 00000004 00 37 00 0D 00 00 00 00 00 04 00
120000 008000 12 00 00 00 80 00

120000 008000 12 00 00 00 80 00

120183002000 12 01 83 00 20 00

40 00 42 0000 0000 28 0000 40 00 42 00 00 00 00 28 00 00

40 00 43 0000 0000 28 0000 40 00 43 00 00 00 00 28 00 00
120000 008000 12 00 00 00 80 00

120180002000 12 01 80 00 20 00

1201 CO 00 FF 00 12 01 CO 00 FF 00

1201 C1 00 FF 00 12 01 C1 00 FF 00

1201 C2 00 FF 00 12 01 C2 00 FF 00

1201 C3 00 FF 0O 12 01 C3 00 FF 00

1400 01 00 FF 00 14 00 01 00 FF OO0

1400 08 00 FF 00 14 00 08 00 FF OO0

1400 1C 00 FF 00 14 00 1C 00 FF 00

40 00 42 0000 0000 28 0000 40 00 42 00 00 00 00 28 00 00
£ >
Select CDB k

An example of the new history entry is here:

Conmand Higtary

1200 COQ0FF OO, (1201 CO0O0FF QO] -
1200 C100FFO0 1, (1201 CT0O0FF 00

1200 C200FFO0 1, (1201 C200FF 00

12001 C300FFOO 1, (1201 CI00FF 00
140001 OOFFOO 1, (1A 0001 O0OFF OO
140008 00FF OO 1, (140008 00FF 00
1A00TCOOFFOO 1, [MEIEHEEIEIFFEIEI]

40 004200000000 280000 1,40 0042 0C
A0 004300000000 280000 1,140 00420C
140008 00 FF OO 1, [1.&EIEIEIEEIEIFFEIEI]
1A008800FF OO 1, (1A 00E200FF00)
=DATA_OUT=*,32,00,00,00,08,00,00,00,00,00,C
151100002000 1,(1511 00002000 3

0k

Select the entire CDB sequence by first clicking on the first entry in the Command History window, then
Shift-Clicking on the final entry in the Command History window.



Once the commands have been selected, click the Execute button to send the sequence of commands to
the selected device.

The results of each CDB will be displayed in the Command Results window. /0 completion time, status,
and REQUEST SENSE data if a CHECK CONDITION occurs will be displayed.

See the description of Added Save to CDB Sequencer File option in this section for instructions on
creating the BAM file.

Display Performa Expiration Date

The Performa Expiration Date and version number are now displayed when you click the Help->About
SCSItoolbox main menu choice as shown here:

Product Information

' SC5I Toolbox3d? Version 7. 0. 0 (bunild) Y0626
EJ SCSI Toolbomx. LLC (3033 972-2072

Serial # CKO04001234 (FFF13482) Buffer = 2560 KE MaxIO = 2560 KE

Performa Ezpiration Date: 672008 Eev Version: 7.0.0
COptional Modules: h

Work=station Prep: In=ta d Jukebox: In=talled

Media Copy: In=talled Fibre: In=talled

Programming: In=talled Hultiple HA: In=talled

Copyright 2005 SC5T Toolbox., LLC. All rights
reserved .

Returnl

Be sure to keep your Performa subscription up to date so you will have access to the latest features of
the SCSltoolbox Suite!




Default Driver Selection Option

The main menu Options->Change Driver choice allows you to easily change between the available
drivers for SCSltoolbox and Developers Toolbox.

You may want to try changing the default driver if you are having issues where certain devices are not
showing up in the device display.

If you change drivers using this option you will need to exit and then re-launch SCSltoolbox for the
change to take effect.

Change Driver Setting

Change Dnver Setting




Launch Bus Analyzer from within STB

Use this main menu choice to launch BAM while running the SCSltoolbox

C5l Toolbox32

File Adapter Options Disk ATA Commands SAF-TE fSEP Advanced Tests Bus Resets Bus Analyzer Buffer

Scripts and Sequences  Help
Scan Bus | Scan System

LUN Print Beports | SafeJukeBox W
Error Logaing :
Target 1: SEAGATE ST34872/C “erzion 0876 File Browse
Capacity = 4353 MB T | ﬂ
ype | None A
T arget.2: FUNTSU MAMNZTS4MC  Version 5207
DIk Capacity = 17752 ME Clear File | Wiew File
-M Target 3 SEAGATE ST34672/C  “ersion 0B7E
DISK Capaciy = 4444 MB Log Perfarmance Data |
E:lr:g:éi;: F#SEEHMEATMSWKE_HSCA Wersion GV Send "A" to COMT: on Errar [
OIS, -

Target & Mot Awvailable

Target B SUPER  GEM3ITE Wergion 0
g il Uinknown Capacity

3
]
-
£

Read Capadty




Command description file choice added to CDB Sequencer
When first entering the CDB Sequencer you will see the name of the command description file that will
be used. You can accept this file, or you can specify another file —

g) CDE File is set to C:YProgram Files\STEVSCSI toolbox32\commands.dat - Use this file?

Yes Mo |




Within the CDB Sequencer you may also change the command description file that is used —

CDB Sequencer

S ave to File

The CDB description files are ascii text files that can be created/edited with any text editor. They can
also be created or modified by using the User Defined CDB command.




Improved Device Discovery method

A newer method of device discover has been implemented that is able to find devices in systems with
non-standard host bus adapter configurations.

Display CHECK CONDITION in Red in CDB Sequencer

If a command sent in the CDB Sequencer results in a CHECK CONDITION the results in the Command
Response window will be displayed in Red, making it easier to see when errors have occurred

CDB Sequencer

opy and Verify,1 - 3A 00 00 00 00 00 00 00 (A
CHECK CONDITION - Sense Data = 05/00/
FO 00 05 00 00 00 00 06
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
iry.1 (12 00 00 00 FF 00)
COMMAND COMPLETE (0.00033608 Sec)
03 00 02 02 31 00 00 00 Clear

33 353 30 45 32 20 20 20 QJ
= =

N BT T [

Load from File

Copy and YWerifp,1 - 34 00 00 00 00 00 00 00 00 00
Inguiry,1 (12 00 00 00 FF 00) Eal
Load BaM File

Cancel




SCSItoolbox32 (STB) Bug Fixes

Fixed READ DEFECT DATA by Logical Block
Fixed Dongle Serial Number display

Fixed 16-byte READ CAPACITY

Fixed display of EVPD SERIAL NUMBER data

Fixed Log Page description file parsing



Manufacturing Module (DMM,TMM) Additional Features & Tests

Added Advanced Options choice to specify location of log files

Open the Advanced Options page by clicking on the Advanced Options button in the Test Setup tab.

The default folder that all log files will be written to is displayed. Click on the Browse button at the far
right of the folder display area to specify another location for the log files.

Disk Advanced Options

X
|
_ Cencal | |

Cancel

C:AworkditSTEY_0_0-706265_Debug -




Manufacturing Module (DMM,TMM) Bug Fixes

Changed file share status of DMM text logfile

The file status is changed to shared - so other programs can open/print from the text log file while a test
sequence is running.



Bus Analyzer Module (BAM) Additional Features & Tests

Added Save to CDB Sequencer File option

You can now record a series of I/O’s to/from a device, and later use the STB CDB Sequencer function to
play back the sequence of commands. This is very useful for capturing and recreating problematic I/0
streams — you can capture 1/0 that is generated by any application.

Be sure that you have only captured I/O to one device at a time when using this option to prevent
contaminating I/O for one device with those commands sent to another device.

Once you have captured an I/O trace use the File->Save to CDB Seq. File choice to create the file

2= BAM by SCSI Toolbox, LLC -
5=8 Edit View Filters Help

Open... Ctrl+0 “od"
Save Ctrl+5

+C

New Ctrl+ A ,1 7

|

Print... Cirl+P
Frint Preview

Print Setup...

Recent File

E

Sort by
Mesus

Improved Trace Save operation
The File->Save choice has been updated to save all phase data from a trace capture.



Added Sense Data interpretation to Individual I/0 display tab
In the case of a CHECK CONDITION the Sense Key, Sense Code, and Sense ASQ hex data is interpreted as
shown —

%2 BAM by 5CSI Toolbox, LLC -

File Edit View Filters Help
> % | [ 5
PO~ BNV
il
Ctr| Device | Phase Type CDB Desc Data Data Length Delta Date ;I Cap Size [MB) ]
32
Sort by
Nexus
|
Performance Monitors  Individual 1/O Information | Raw Data | Trace Peformance Anahrsisl 140 Statia‘.icsl
Originator:  stsclass CDB: 1201C300FF 0D
Device: 6:0:0:0 Bytes Transfemed: &
Operation Code: 12 Inquiry
Ermor Inf ion
SRB Status: C4 Sense Key: 05
Target Status: 02 Sense ASC. 24
Sense ASCO: 00
Sense Data:
ILLEGAL REQUEST
INVALID FIELD IN CDB k
=
Ready BAM Status MUM A




Bus Analyzer Module (BAM) Bug Fixes

Made all functions (Find, Individual I/0, Raw Data, Analysis) work on saved file data as they
do with live data



